W168 Ah, viele Fehlercodes im ECM. Interpretationshilfe erbeten

Diskutiere Ah, viele Fehlercodes im ECM. Interpretationshilfe erbeten im W168 Exterieur, Karosserie, Motor und Fahrwerk Forum im Bereich A-Klasse W168 (1997-2004); Guten Morgen, nachdem meine Elch sich als Lazarus erweist und bisher immer vom Totalschaden wieder auferstanden ist, ereilt ihn wohl nun das...

  1. Azrael

    Azrael Elchfan

    Dabei seit:
    19.09.2015
    Beiträge:
    19
    Zustimmungen:
    20
    Ort:
    Berlin
    Ausstattung:
    Schaltgetriebe, Avantgarde, Radio MB Audio5, Sidebag, AHK
    Marke/Modell:
    1998er A160
    Guten Morgen, nachdem meine Elch sich als Lazarus erweist und bisher immer vom Totalschaden wieder auferstanden ist, ereilt ihn wohl nun das Schicksal vieler Elche vor ihm.

    A160 Schalter mit Klima (Avantgarde) EZ98 KM-Stand 160.000

    Zündkerzen neu, Luftfilter neu, MÖL neu

    Im kalten Zustand sehr unrunder Leerlauf, absacken der Drehzahl und geht auch aus.

    Ansauggeschläuch ist bereits kontrolliert und Dicht, Drosselklappe auch geputzt.

    Fehler habe ich ausgelesen mit iCarsoft i980 und mit moDiag, wobei das i980 mehr Fehler anzeigt.

    moDiag zeigt nur P0170

    i980 zeigt P0130, P0170, P0202, P0203, P0212 (???), P0214, P0217 (i980 zeigt normale Öl und Wassertemperatur), P0220, P0221, P0224, P0228, P0246, P0256, P2432, P2625, P2727 und noch Abwandlungen davon mit diversen Ziffern hinten dran. es gibt auch noch Codes Buchstaben in den ersten vier Stellen. Insgesamt 50 Fehlercodes

    ECM ist Softwarestand 14/98
    MB No: 0265450532
    Hersteller VDO

    Benzindruck muß ich noch messen, die Pumpe habe ich aber vor ca 6 Jahren bereits gegen eine neue getauscht, da Anschlußstutzen beim Schlauchwechsel abgebrochen *ulk*.

    Spritfilter ist ca. 1,5 Jahre alt.

    Nimmt in der Warmlaufphase schlecht Gas an im Teillastbereich. Wenn warm, dann läuft er normal.

    Fehler habe ich schonmal mit nem Werkstattprogramm versucht zu entschlüsseln, deutet halt einiges auf MSM oder Kabelbaum hin, stand oft was von Massefehler oder Kurzschluß auf Plus etc. drin.

    Der Elch ist Laternenparker und wurde von Eichhörnchen als Haselnusshöhle missbraucht 8|.

    Sogar aus dem Luftfiltergehäuse habe ich die ausgelutschten Schalen rausgeholt. Händeweise vom Zylinderkopf gekratzt.

    Der obere Stecker vom MSM hat ein paar Korrosionsspuren, ebenso die Pins am MSM. Alles mit Kontaktspray behandelt und versucht zu säubern, brachte aber keine Verbesserung.

    Bevor ich nun das MSM zur Überprüfung einschicke (gibt es noch aktuelle Empfehlungen dazu?) würde ich mal den Kabelbaum durchmessen über die Stecker vom Steuergerät. Auf Werkstattsoftware mit entsprechenden Werten kann ich zugreifen.

    Vielleicht kann jemand von den erfahrenen Elektronikern mir mal helfen ob das Sinn macht oder eher stumpf MSM als Schuldiger zu bennen ist.

    Vielen Dank

    Grüsse aus Berlin

    Christoph
     
  2. Anzeige

  3. #2 Heisenberg, 11.06.2022
    Zuletzt bearbeitet: 11.06.2022
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    12.540
    Zustimmungen:
    17.415
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance - Mopf Umbau
    Marke/Modell:
    Elch 168.008 A170 CDI Ez. 1999/06 - AT - Km: 187624 (04/2022) ...
    Stell den Wagen bei der nächsten DEMO von den Autonomem in der richtigen Straße ab und lass ihn dir Abfackeln.
    Dann bekommst du wenigstens vernünftiges Geld von der Versicherung und kannst dir was neues ergattern.
    Wenn du nur innerhalb Berlin herum fährst, nutze das 9€ Ticket .. .das kannst du in "vollen Zügen" genießen.

    Sorry für den Hohn und Sarkasmus, aber ich kann leider nicht anders in dieser zeit.
    :D

    Sarkasmus-Sprueche-Beispiel-Witz-Ironie.jpeg
     
  4. Azrael

    Azrael Elchfan

    Dabei seit:
    19.09.2015
    Beiträge:
    19
    Zustimmungen:
    20
    Ort:
    Berlin
    Ausstattung:
    Schaltgetriebe, Avantgarde, Radio MB Audio5, Sidebag, AHK
    Marke/Modell:
    1998er A160
    Haha, Du warst auch schonmal lustiger.
    Dieses Auto ist ja schon ein Untoter. In den letzten 5 Jahren dreimal unverschuldete Totalschäden, zweimal den parkenden Elch beschädigt und letztes Frühjahr der Abschuß auf der Autobahn. Das Ding ist so zäh und fährt ja auch jetzt noch. Nur halt kalt etwas unwillig. Hat noch 20Monate TÜV, vorher ist nix mit Ruhestand.
    Christoph
     
    Obi und Heisenberg gefällt das.
  5. #4 Heisenberg, 11.06.2022
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    12.540
    Zustimmungen:
    17.415
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance - Mopf Umbau
    Marke/Modell:
    Elch 168.008 A170 CDI Ez. 1999/06 - AT - Km: 187624 (04/2022) ...
    :D aber der letzte Tipp ist effektiver ..

    Vorausgesetzt alle Beiträge sind Pünktlich bezahlt.
     
  6. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.895
    Zustimmungen:
    4.397
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor Mopf + Suzuki GSXF 600 fürs Hobby
    Moin,
    ich habe mir mal die Mühe gemacht die Fehlercodes zu entschlüsseln.

    @Azrael Das wäre eigentlich deine Aufgabe. Google hast du doch bestimmt ?

    Für mich hört sich das insgesamt so an, als wenn die Batterie schwach ist oder die Massebänder verfault sind. Ich denke, ein großer Anteil der Fehler sind Folgefehler.

    Ich würde so vorgehen: Alle Fehler löschen und in ein paar Tagen ( nach ein paar Fahrten ) den Fehlerspeicher erneut auslesen. Dann hat man nicht so ein Wirrwarr an Codes und kann die wichtigen besser raus finden.

    Man kann in der Zwischenzeit, als geneigter Nutzer, die Massekabel kontrollieren, besonders im Motorraum ( am Wasserkasten und links und rechts an den Motorhalter vorn zu den Längsholmen ) und unten an der Ölwanne ( das dicke schwarze Kabel ). Nicht falsch ist auch die Kabelbäume auf Scheuerstellen abzusuchen, vor allem den einen Kabelbaum zum Motorsteuergerät, der direkt am Luftfiltergehäuse entlang läuft.

    Auch ein kurzer Batterietest ist schnell gemacht ( stehender Motor ca. 12,6 Volt, laufender Motor ca. 14 Volt ) .

    Klaus
     
    Obi gefällt das.
  7. #6 Ralf_71287, 12.06.2022
    Ralf_71287

    Ralf_71287 Elchfan

    Dabei seit:
    21.10.2018
    Beiträge:
    895
    Zustimmungen:
    1.364
    Beruf:
    Elektrotechniker | Em-Rentner Bj.67
    Ort:
    Stuttgart | Weissach
    Ausstattung:
    Elegance
    Marke/Modell:
    99er W168 Schalter A140 ~250tkm| Sommer: 02er Smart 450 Cabrio ~300tkm
    Ob das wirklich die Autonomen waren/sind - wer weiß. Kann auch die Polizei oder der Geheimdienst sein um Unruhe zu stiften.
    Die vermummten Steinewerfer in Hamburg vor 25 Jahren war auch die Polizei. Das weiß ich von einem Bekannten, die wollten so einen Steinewerfer verprügeln bis er seinen Dienstausweis gezeigt hat.
     
  8. #7 Hans14468, 13.06.2022
    Hans14468

    Hans14468 Elchfan

    Dabei seit:
    04.05.2022
    Beiträge:
    135
    Zustimmungen:
    167
    Ausstattung:
    1,6 l Benziner, Schaltgetriebe, Ladeboden
    Marke/Modell:
    Vaneo W414 (12/2005)
    Gerade dann ... .
     
  9. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.895
    Zustimmungen:
    4.397
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor Mopf + Suzuki GSXF 600 fürs Hobby
    @Heisenberg , @Ralf_71287 , @Hans14468
    Was hat der Themenstarter mit seiner begründeten und umfangreichen Frage falsch gemacht, das dieses Thema so in eine politische und wenig hilfreiche Richtung gezogen wird ? Habt ihr alle Langeweile ?

    Klaus
     
  10. Anzeige

    Schau mal hier: (hier klicken). Dort findet man Infos und Antworten.

    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 Azrael, 13.06.2022
    Zuletzt bearbeitet: 13.06.2022
    Azrael

    Azrael Elchfan

    Dabei seit:
    19.09.2015
    Beiträge:
    19
    Zustimmungen:
    20
    Ort:
    Berlin
    Ausstattung:
    Schaltgetriebe, Avantgarde, Radio MB Audio5, Sidebag, AHK
    Marke/Modell:
    1998er A160
    Hallo Klaus,

    danke für Deine Antwort, die Massekabel hatte ich auch bereits im Verdacht und habe mit einem Starthilfekabel Masse von der Batterie zum Motor und mit dem anderen zur Karosse gelegt. Leider keine Verbesserung, tauchen immer die gleichen Fehler auf. Benzindruck am Rail habe ich auch gemessen, 3,5bar zeigt das Chinamannmanometer, sollte passen. Batteriespannung ist auch soweit in Ordnung, bei Leerlaufdrehzahl sind es 13,84V, Batterie alleine hat 12,5V. Letzten Winter ist mir eine Batterie über die Wupper gegangen, da hat er trotz schlechter Batterie nicht gemuckt.
    Die Codes habe ich wie geschrieben ja bereits entschlüsselt, deshalb die (? ?) beim Fehler für die Einspritzdüse an Zylinder 12. ich schrieb ja auch, dass vieles auf Kabelbaum UND MSM hindeutet. Den Kabelbaum hab ich nun schon mehrfach hin und her bewegt, Scheuerstellen sehe ich da auch keine. Ich probiere am WE mal den durchzumessen, wenn das nix bringt, fahr ich mit dem MSM mal zum Steuergerätefuzzi und lasse es testen. Reparatur soll hier im dicken B 159€ kosten. Mal checken ob die dafür nur nen Widerstand einlösen oder die Plättchen tauschen. Das ist mir zu filigran, das traue ich mich nicht zu löten.
    Für weitere Hinweise und Denkanstöße dankbar.
    Grüße
    Christoph

    PS: Ich habe die Probleme halt von jetzt auf gleich bekommen, keine schleichende Verschlechterung. Axo, Drosselklappe und LMM hab ich bereits geputzt

    PPS: Fehler Löschen habe ich dann vor jedem neuen Schritt gemacht, es wird immer nach ein paar Minuten Fahrt die gleiche Masse an Fehlern angezeigt.
     
    Hans14468 gefällt das.
  12. Azrael

    Azrael Elchfan

    Dabei seit:
    19.09.2015
    Beiträge:
    19
    Zustimmungen:
    20
    Ort:
    Berlin
    Ausstattung:
    Schaltgetriebe, Avantgarde, Radio MB Audio5, Sidebag, AHK
    Marke/Modell:
    1998er A160
    Lazarus lebt wieder, nachdem ich alle anderen Fehlerquellen (Falschluft, Massefehler, Bakterie) ausgeschlossen habe, habe ich das Steuergerät am Freitag zur Reparatur des LMM gegeben.

    Heute hat meine Chefin es in Steglitz wieder abgeholt, gerade eingebaut, die 80 Fehler die drin waren gelöscht und Abfahrt.

    Was soll ich sagen: Läuft sofort wieder sauber durch, hat gefühlt wieder mehr Leistung und der Fehlerspeicher bleibt leer.

    Auf ein langes Leben

    Grüße aus Berlin

    Christoph
     
    Christian Martens, Hans14468, Heisenberg und 2 anderen gefällt das.
Thema:

Ah, viele Fehlercodes im ECM. Interpretationshilfe erbeten

Die Seite wird geladen...

Ah, viele Fehlercodes im ECM. Interpretationshilfe erbeten - Ähnliche Themen

  1. W169 Benzinreserve - wie viele km noch?

    Benzinreserve - wie viele km noch?: Hallo, ich hätte das Thema auch unter Elektrik einstellen können, aber hier wird es besser aufgehoben sein. Neben der ersten A-Klasse haben wir...
  2. W246 Viele Fehlermeldungen. Nach Batterie abklemmen kein starten möglich

    Viele Fehlermeldungen. Nach Batterie abklemmen kein starten möglich: Hallo Leute, Wir sind gerade aus Schweden mit unserer B klasse 180 richtung Deutschland gefahren, haben nun ein riesen Problem und hocken in...
  3. Vielen Dank an alle Foris und alles Gute

    Vielen Dank an alle Foris und alles Gute: Werte Foris, da ich mein kleines Benzerl verkauft habe und auf Audi umgestiegen bin, möchte ich mich verabschieden und für die Tipps und guten...
  4. W169 Biete Chrom Türpins f. viele Modelle NEU!!!

    Biete Chrom Türpins f. viele Modelle NEU!!!: Hallo, ich habe noch neue Chrom Türpins übrig. Passend für alte A-Klasse sowie das neue Modell, B-Klasse, CLA-Klasse. GLA-Klasse etc. Sie werden...
  5. W168 Wie viele Umlenkrollen ????

    Wie viele Umlenkrollen ????: Tach zusammen!!! ganz doofe Frage: Bei meinem w168 OHNE Klima , "pfeift" so richtig schön Drezahlabhängig. Also wollte ich mir mal den Stress...