T245 Getriebe Notlauf, Fehler P0840 und P0841

Diskutiere Getriebe Notlauf, Fehler P0840 und P0841 im T245 Exterieur, Karosserie, Motor & Fahrwerk Forum im Bereich B-Klasse T245 (2005-2011); Guten Tag, haben hier das Problem dass von unserer B-Klasse das Automatikgetriebe ständig in den Notlauf geht. Es handelt sich um das...

  1. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    Guten Tag,

    haben hier das Problem dass von unserer B-Klasse das Automatikgetriebe ständig in den Notlauf geht. Es handelt sich um das CVT-Getriebe 722.8 - Im Fehlerspeicher stehen die Fehler P0840 und P0841 - was soviel bedeutet wie Hydraulikdruck im Stand und in Fahrt unplausibel. Da vor zwei Jahren ein Getriebeölwechsel gemacht wurde, kanns ja nicht am Öl liegen. Also Getriebeölwanne ab, Schaltschieber raus und nachgesehen was da los ist, da ja die ersten Schieberkästen diese Schwachstelle mit dem Riss an der Seite haben. Aber unser Fahrzeug hatte bereits schon einen überarbeiten Schaltschieberkasten und ich kann auch keinen Riss erkennen, trotz Lupe und Taschenlampe. Dann bin ich dazu übergegangen alle Schieber zu überprüfen ob da evtl. die Federn gebrochen sind - und ich muss sagen dass alle Federn ok sind und alle Schieber sauber laufen, ausserdem macht der Schaltschieberkasten einen sehr sauberen Eindruck, keine Ablagerungen, kein schwarzes Öl, fast kein Abrieb an den Magneten in der Ölwanne, auch die Siebe an den Magnetventilen sind sehr sauber - kurzum: Ich weiss jetzt nicht mehr was ich machen soll. Den Schieberkasten in seine zwei hälften zerlegen trau ich mir ohne Dokumentation nicht zu - von daher meine Frage: Kennt sich hier jemand echt gut aus und hat noch einen Tipp oder eine Dokumentation zu dem Schieberkasten? Ich hab wie gesagt keine Lust den aufzuschrauben und dann fallen mir Siebe und Kugeln entgegen ohne eine Chance zu erkennen wo was war. Zu Mercedes brauch ich auch nicht fahren, die bauen mir nur ein neues Getriebe ein (6500€)

    Noch zur Anmerkung - wenn das Getriebe im Notlauf ist, zeigt mir der Primärdrucksensor im Getriebe einen Druck von 30bar an, also scheint ja die Regelung zumindest zum Teil zu funktionieren.
     
  2. Anzeige

  3. #2 Heisenberg, 29.05.2021
    Zuletzt bearbeitet: 29.05.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    Hier dürfte was dabei sein, ich meine in Teil 2 !?
    Meistens sind aber die E-Ventile der Übeltäter ....


    Nachtrag:
    Hier habe ich auch noch was gefunden: https://at-manuals.com/manuals/722-8-mercedes/
    Es gibt auch Reparaturhandbuch, ist aber teuer ... https://mbmanuals.com/transmissions/mb7228trans.htm
    Selbst die 25$ für die Downloadversion gebe ich nicht aus, da ich kein 722.8 habe ... noch nicht :D
    Sonnst würde ich es Laden und hier zur Verfügung stellen.
    (Wird aber wohl wieder eine Rußen oder CZ. Version sein)
     

    Anhänge:

  4. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    Danke, das hab ich auch gefunden, aber leider sieht man dort die Position der Kugeln und siebe nicht. Und einfach auf gut Glück die Teile zu trennen ist mir zu gefährlich.
    Die Ventile... kann man die einfach mit 3Volt bestromen und so testen?

    Ein Instandsetzer meinte auch dass ein elektrischer Fehler im Steuergerät ausgeschlossen ist.
     
  5. #4 Heisenberg, 29.05.2021
    Zuletzt bearbeitet: 29.05.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    Ja, musst du nur tickern! (Morse Zeichen geben)
    Man hört ob sie vernünftig Schalten oder nicht, Bitte bei diesen Ventilen darauf achten das sie wieder an die gleiche Position verbaut werden, die sind Selbstlernend und können nicht einfach untereinander getauscht werden .... wie zb. beim W168.

    Schau dir das mal an, ist zwar nicht vom Elch, aber schon die neue Generation EHS



    bei 18:26 ...
     
    stuermi gefällt das.
  6. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    dankeschön. ich werd morgen einfach die ventile testen und dann schau ich weiter. Allerdings stell ich mir jetzt schon die frage: wie mache ich weiter, wenn die ventile morgen alle schalten? Der Fehler MUSS ja im Schieberkasten liegen... kein anderes Teil im Getriebe ist an einer Druckregelung beteiligt. Bleibt noch die Ölpumpe, aber die fördert ja - denn sobald das Getriebe aufs Notprogramm schaltet, kann man am Primärdrucksensor sehen, dass 30bar anliegen - das soll auch laut Doku so sein.
     
    Gast14468 gefällt das.
  7. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    also wie erwartet, die Schaltventile klicken ganz ganz leise. eines wenn man spannung anlegt und die anderen 3 wenn man sie wegnimmt... jetzt bin ich am ende.
     
    Gast14468 und Heisenberg gefällt das.
  8. #7 Heisenberg, 30.05.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    "Zitat"
    Es gibt ebenfalls Fehlercodes, die auf einen mechanischen Defekt in dem CVT hinweisen, sofern tatsächlich etwas an der Mechatronik falsch läuft. Durch Verschleiß zum Beispiel kann zu viel Spiel mit entsprechendne Folgen entstehen. Die Fehlercodes, welche wir hierbei sehen, weisen dann oft auf die Funktion des Schubgliederbandes oder einen fehlerhaft gemessenen Öldruck hin:

    • 0841 While driving, the actual hydraulic pressure is implausible in comparison with the specified hydraulic pressure in the CVT

    • 0894 The steel thrust belt in the CVT is slipping

    • 0896 Impermissible adjustment of the step-down ratio in the CVT
    Quelle:
    https://www.actronics-gmbh.de/acinsights/mercedes-benz-temic-vgs-722-8


    Evtl. hilft auch eine freundliche Nachfrage bei diesem Getriebe Onkel: https://www.barsegar-kfz.de/getrieb...-getriebesteuerung/7728-cvt-steuereinheit.php
     
    Gast14468 gefällt das.
  9. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    also ich bin mit meiner recherche weitergekommen. Ein Instandsetzer wusste schon was es sein kann: Schieberkasten defekt - es soll wohl auch Schieberkästen geben die optisch komplett in Ordnung sind, aber eingebaut trotzdem nicht funktionieren
    ODER
    Das Getriebe besteht ja aus zwei Hälften, dazwischen ist eine Dichtung und dort gibt es wohl auch ölführende Bohrungen die miteinander verbunden werden - dort soll diese Papierdichtung gerne kaputt gehen und es tritt unkontrolliert Druck aus. Bei der Laufleistung von 200tkm vermutet der Instandhalter: 30% Schieberkasten oder 70% diese Dichtung. Testen kann man dies nur wenn man einen funktionierenden Schieberkasten montiert und wenn der Fehler weg ist, wars das. Ist der Fehler noch da, dann ist es die Dichtung.

    Hört sich erstmal nicht so schlimm an, allerdings ist es so, dass die Original-Papierdichtung wohl nicht mehr gibt, sondern nur eine Metalldichtung - die Metalldichtung ist natürlich etwas dicker und dann muss der Variator neu eingestellt werden - wie hat man mir nicht verraten, vermute mal mit einer Scheibe, die der Dicke der Metalldichtung entspricht. Jetzt weiss ich was kaputt ist, aber weiterhelfen tut mir das auch nicht :D
     
    Heisenberg gefällt das.
  10. #9 Heisenberg, 01.06.2021
    Zuletzt bearbeitet: 01.06.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    Ist leider auch beim W168 Automatik so!

    Bei MB ein Problem! für mein 722.7xx Getriebe musste ich auch lange suchen und habe jemanden gefunden der mir eine (Original) besorgen konnte.
    Ich wollte es nicht wieder mit Dichtmasse machen.

    Nachtrag:
    Für deine Dichtung (Dichtbeilage) gibt es zwei Teile Nummern!
    1: a1693711780 - bis Getriebe - 290950
    2: a1693713980 - ab Getriebe - 290951

    Preise bis 15€ sind Realistisch.
     
  11. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    Wie aufwändig ist es, das Getriebe in seine Hälften zu zerlegen?
    Gibt es eventuell eine Anleitung zum Schubband-Wechsel? Da müsste das ja mit beschrieben sein.

    Bleibt nur noch zu klären, was man gegen die breitere Dichtung tut.
     
  12. #11 Heisenberg, 01.06.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    Schau mal ins entsprechende Unterforum, da habe ich mal reichlich material zum Getriebe bereitgestellt.
     
  13. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    Danke, da ist tatsächlich eine Teileliste vom 722.8 - super! Da sieht man auch schön die Form der Dichtung, die die beiden Getriebehälften zusammenhält und schon allein an der Form kann man erkennen dass die Aussage vom Instandsetzer stimmen muss/kann. Dabei steht auch, dass diese Dichtung durch eine andere Teilenummer ersetzt wurde - das hat mir der Instandsetzer auch gesagt. Leider ist die neue Dichtung dicker und er meinte was von: Variator muss neu eingestellt werden - da find ich leider keine Informationen dazu. Werde den Händler aber bei Bestellung drauf ansprechen.

    Heute war ich ein bisschen fleissig, ich habe begonnen das Getriebe auszubauen - den Achsträger hab ich raus - Motor baumelt an einer Kette im Motorraum - und alle Schrauben vom Getriebe sind ab, bis auf die 2 vom Anlasser - dazu muss ich den Motor nochn kerniges Stück ablassen um da ranzukommen - und um das Getriebe abzuflanschen sowieso. Selbst mit demontierten Achsträger ist da zu wenig Platz.
     
    Heisenberg gefällt das.
  14. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    soo... getriebe ist raus
    habs geöffnet und das schlimme daran: Es ist bereits eine Metalldichtung verbaut! Wahrscheinlich hat der Vorbesitzer da schonmal ne reparatur durchführen lassen. Die Dichtungen sind in einen dermaßen guten Zustand dass ich sie wiederverwenden werde, die haben keinen kratzer. Auch das Getriebe selbst sieht sehr gut aus, muss dazu aber sagen dass ich es nicht weiter zerlegt habe um jedes Detail zu sehen. War auch kein Abrieb im Öl - also sieht tadellos aus, sofern ich das als Halblaie beurteilen kann.

    Ich werds wohl wieder einbauen und dann den Schaltschieber ersetzen.
     
    Heisenberg gefällt das.
  15. #14 Heisenberg, 05.06.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    Ich hoffe du hast reichlich Fotos gemacht ?
     
  16. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    leider nur sehr wenig, ich wollte einfach fertigwerden. aber ich werd sie zu einem späteren Zeitpunkt dann hochladen.
    hab gestern das Getriebe wieder eingebaut und einen neuen Schaltschieber eingebaut. Nun, jetzt bekomm ich nur noch eine einzige Fehlermeldung: Das Schubgliederband rutscht. :( Entweder ist dieser überholte Schieberkasten auch defekt oder es liegt tatsächlich im Getriebe selbst ein größerer Fehler vor.
    Das komische ist nur: solange das Getriebeöl kalt ist, funktioniert alles bestens. Ab einer bestimmten Temperatur aber, geht es in den Notlauf. Zusätzlich rutscht das Schubband auch nur auf "D" - Bei "R" ist alles in Ordnung.Werde wohl oder übel das Getriebe tauschen müssen.
     
  17. #16 Heisenberg, 13.06.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    Wurde das Korrekte und Vorgeschriebene Öl verwendet?
     
  18. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    jawohl, mit der 236.2 freigabe... Ölstand passt auch - man kann ja auch so 10km normal fahren - dann fängt der riemen an zu rutschen, man hat kurz keinen vortrieb mehr und dann wenn es in den notlauf geht kann man wieder weiterfahren.
     
  19. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    HALT

    Ist doch das falsche Öl. Es hat zwar die 236.2 Freigabe - darf aber nicht in CVT-Getrieben verwendet werden. Da hab ich nicht aufgepasst, ich dachte immer wenn eine Spezifikation erfüllt ist, dann passt das. Sowas ist mir noch nicht passiert. Nun gut, das Öl war nur ein paar km drinn und ich werde es ablassen und damit den Getriebeölkühler spülen (da der Fehler ja nur kommt wenn es warm wird) und anschließend neues einfüllen.
    Ich werde weiter berichten.
     
    Heisenberg gefällt das.
  20. Anzeige

    Schau mal hier: (hier klicken). Dort findet man Infos und Antworten.

    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  21. #19 Heisenberg, 14.06.2021
    Heisenberg

    Heisenberg
    Moderator

    Dabei seit:
    16.08.2017
    Beiträge:
    10.407
    Zustimmungen:
    14.484
    Beruf:
    Frührentner - PLS Elektroniker & Lebenskünstler
    Ort:
    Ungarn - Balaton (Südufer)
    Ausstattung:
    Elegance
    Marke/Modell:
    Elch 168.008 A170 CDI Bj. 1999/06 - AT - Km: 184964 (02/2021) ...168.035 EVO 210 Bj. 2003/12 - AT - Zerlegt!
    236.2 ist nicht 236.20 !
    Es müssen auch die folge Zahlen stimmen, 236.1 darf auch nicht bei 236.10 oder 236.11 hinein.
    Automatik Getriebe sind da ganz penibel.
     
  22. lynx83

    lynx83 Elchfan

    Dabei seit:
    28.05.2021
    Beiträge:
    21
    Zustimmungen:
    11
    ich bin so blöd!! beim ölstandkontrollieren ist mir auch aufgefallen dass das Öl geschäumt hat. Vermute mal dass das Getriebe funktioniert hätte wenn ich gleich das richtige Öl eingefüllt hätte. Ich hab nur noch eine Fehlermeldung und die besagt, dass der Riemen rutscht.
    Wie gesagt, ich lasse das falsche Öl ab, spüle damit trotzdem den Ölkühler frei und fülle richtiges Öl ein. Ich lasse auch das Öl am Wandler ab und versuch es nochmal.
    Sollte sich das Fehlerbild massiv verbessern mach ich ne Woche drauf nochmal einen Ölwechsel.
     
    Heisenberg gefällt das.
Thema:

Getriebe Notlauf, Fehler P0840 und P0841

Die Seite wird geladen...

Getriebe Notlauf, Fehler P0840 und P0841 - Ähnliche Themen

  1. W414 Getriebe verliert Öl

    Getriebe verliert Öl: Hallo zusammen, Kann jemand aus Erfahrung sagen woher der Ölverlust kommt?? Automatikgetriebe verliert oberhalb Öl. Läuft dann genau an der...
  2. W169 Olwechsel Getriebe A150

    Olwechsel Getriebe A150: Hallo an alle Mitglieder hier, weis jemand zufällig ob beim Schaltgetriebe A150, W169 Benziner ein Getriebeölwechsel vorgesehen ist, wenn ja bei...
  3. W414 Automatik getriebe zeigt F an und leuft auf notlauf

    Automatik getriebe zeigt F an und leuft auf notlauf: Hi habe folgens Probleme mit mein vaneo er fahrt nur in notlauf und zeigt F Und epc an laut Diagnose folgende fehler kann mir jemand sag wie...
  4. W168 Automatik Getriebe Problem -- Notlauf

    Automatik Getriebe Problem -- Notlauf: Hallo Elchgemeinde Bin erst seit wenigen Monaten hier im Forum und hatte bisher keine Not hier Problem zu posten. Ich fange mal kurz an: wir...
  5. W168 Getriebe springt in den Notlauf

    Getriebe springt in den Notlauf: Hallo zusammen. Anfang des Jahres habe ich die A-Klasse von meinem Opa übernommen. Es handelt sich um einen A 160 Automatik Bj. 97, mit gerade...