W168 Hilfe bei Fehlersuche - Motorsteuergerät

Diskutiere Hilfe bei Fehlersuche - Motorsteuergerät im W168 Exterieur, Karosserie, Motor und Fahrwerk Forum im Bereich A-Klasse W168 (1997-2004); Vielleicht hat jemand Zeit und kann mir hier helfen? Irgendwie habe ich entweder Werkstätten, die keine Lust auf alte Fahrzeuge haben, oder die...

  1. #1 a140l_driver, 12.01.2022
    Zuletzt von einem Moderator bearbeitet: 12.01.2022
    a140l_driver

    a140l_driver Elchfan

    Dabei seit:
    12.01.2022
    Beiträge:
    5
    Zustimmungen:
    3
    Ort:
    Emmendingen
    Marke/Modell:
    A140L 2003 ca. 230000km
    Vielleicht hat jemand Zeit und kann mir hier helfen? Irgendwie habe ich entweder Werkstätten, die keine Lust auf alte Fahrzeuge haben, oder die innerhalb von 5 Minuten schon wissen was es ist (genial oder... -"Motorsteuergerät kaputt"!!). Wäre super :-)

    Was bisher geschah:
    Springt gar nicht mehr an, Batterie getauscht und Drosselklappe gereinigt (hatte aber nichts gebracht), dann Kurbelwellensensor und Benzinpumpe am Tank getauscht. Läuft wieder.

    Seit ca. etwas über einem Jahr ist der Leerlauf unrund, erst kaum hörbar, inzwischen extrem, bis zum Motor aus.

    Nichts im Fehlerspeicher, zumindest mit ELM-Bluetooth und Carscanner.

    Zum Testen kann ich ihn einfach laufen lassen. Startet, Drehzahl erst 1400, dann nach und nach auf 800. Geht bis auf 60 Grad Wassertemperatur (so ca. 10 Min), dann fängt die Drehzahl kräftig an zu schwanken, manchmal geht der Motor komplett aus. Kann sofort wieder neu starten, dann läuft er aber nur noch 1-2 Minuten, selbes Spiel.

    Nochmal dasselbe, Motor wieder kalt, etwas Gas (ca. 1500U/min), Temperatur geht auf 70 Grad, gleiches Ergebnis.

    Tankdeckel auf oder Heizung volle Kanne bringt keine Änderung (ja, hab hier alles gelesen, was damit zu tun haben könnte :-)).

    Also irgendwas temperaturabhängiges? Eine Werkstatt sagt, ohne den A140L gesehen zu haben, Motorsteuergerät reparieren lassen (wegen LMM wahrscheinlich ?). Gibt es noch was, was ich schauen oder nachschauen lassen kann?

    WDB1681311J916818
    Baujahr 2003
    A140L
     
    LopatarA190 gefällt das.
  2. Anzeige

  3. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.827
    Zustimmungen:
    4.143
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor + Suzuki GSXF 600 fürs Hobby
    Moin,

    das der Luftmassenmesser beim W168 Benziner kaputt geht ist kein Geheimnis und könnte auch die Ursache für ihre Fehler sein.

    Klaus
     
    LopatarA190 gefällt das.
  4. #3 a140l_driver, 12.01.2022
    a140l_driver

    a140l_driver Elchfan

    Dabei seit:
    12.01.2022
    Beiträge:
    5
    Zustimmungen:
    3
    Ort:
    Emmendingen
    Marke/Modell:
    A140L 2003 ca. 230000km
    Danke, Klaus, also ausbauen und an einen von den Shops schicken, die man im Internet findet.
    Hab mal geschaut, so 200 bis 400 Euro sind die Angebote, allerdings immer mit dem "*", dass es natürlich auch teuerer werden könnte.
    Hat schon jemand gute Erfahrungen mit wem gemacht?

    Könnte es noch was anderes sein, was ich vorher testen sollte?
    Hab noch geschaut, die Lambdasonde vor dem Kat springt so zwischen 0,2 und 0,8V hin und her, die andere ist stabil bei 0,5V. Könnte passen, ohne dass ich jetzt wirklich Erfahrung habe (?).

    Danke Euch
    Bernd
     
    LopatarA190 gefällt das.
  5. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.827
    Zustimmungen:
    4.143
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor + Suzuki GSXF 600 fürs Hobby
    Moin,

    wurde beim Kraftstoffpumpenwechsel auch der Benzinfilter erneuert ?

    Hast du vor kurzem nochmals den Benzindruck vorn am Motor gemessen ?

    Ist der Kabelbaum zum Motorsteuergerät in Ordnung und ohne Scheuerstellen ?

    Ist der Wagen schon mit einer Diagnose ausgelesen worden, die auch die Livewerte anzeigt ?

    Ist das Relais der Kraftstoffpumpe schon gewechselt worden ? Man kann zum Testen einfach das Relais der heizbaren Heckscheibe nehmen ( siehe Relaisplan im Batteriefach ) .

    Ist der gesamte Ansaugweg dicht, so das Falschluft ausgeschlossen werden ?

    Mehr fällt mir auf die Schnelle und ohne den " Patienten " gesehen zu haben nicht ein.

    Klaus
     
    LopatarA190 und Christian Martens gefällt das.
  6. #5 Neoback, 13.01.2022
    Neoback

    Neoback Elchfan

    Dabei seit:
    16.05.2020
    Beiträge:
    87
    Zustimmungen:
    52
    Beruf:
    Anlagenmechaniker, Techniker Maschinenbau
    Ort:
    59425 Unna
    Ausstattung:
    W168, A190, Bj. 1999, Automatik, Elegance, Benzin,APS 30
    Marke/Modell:
    Mercedes Benz A190
    Zwei hätte ich noch, Ventile undicht ?
    Ich hatte mal das Problem, das sich ein Eichhörnchen ein Nest in meinem Luftfilter gebaut hatte und da dann Nüsse, Blätte usw. drin waren. Ich weiß auch nicht, wie es das Viech geschafft hatte, aber da hatte ich auch solche Probleme gehabt. Das Eichhörnchen hatte auch ein Loch in den Luftfilter gefressen....schau mal nach ob es dem soweit gut geht. Seitdem weiß meine damalige 3 Jährige Tocher, was ein Luftfilter ist.

    Gruß
    Neoback
     
    LopatarA190 gefällt das.
  7. #6 a140l_driver, 14.01.2022
    Zuletzt bearbeitet: 14.01.2022
    a140l_driver

    a140l_driver Elchfan

    Dabei seit:
    12.01.2022
    Beiträge:
    5
    Zustimmungen:
    3
    Ort:
    Emmendingen
    Marke/Modell:
    A140L 2003 ca. 230000km
    Hallo, gute und schlechte Nachrichten:

    - Benzinfilter wurde schon erneuert.
    - Kabelbaum sieht eigentlich gut aus, zumindest was ich so von oben sehe. Wackeln/ziehen/bewegen an denen vom Steuergerät ändert nichts.
    - Relais tauschen macht (leider) keinen Unterschied.
    - Ansaugweg, hmm, zumindest keine Risse sichtbar, das lasse ich aber checken.
    - Diagnose mit einem Profigerät noch nicht. Daten zeichnet der CarScanner auch auf, hat sogar ein eigenes W168 Profil. Was wäre interessant?
    - Luftfilter ist gecheckt, nichts was (noch) lebt darin, zumindest was man ohne Mikroskop sieht :-)
    - Benzinverbrauch liegt so bei 6,5 bis 7 l/100km, hat sich über die Jahrzehnte kaum verändert, fahre hauptsächlich Landstraße, ist ok?
    - Ventile undicht kann wohl auch nur eine Werkstatt checken

    Ok, jetzt zu den schlechten Nachrichten, beim letzten Testlauf kam auf einmal Benzin raus, unten im Bereich des Beifahrersitzes.
    Eine Werkstatt fährt den Elch nun in den ersten Stock und schaut nach. Schlauch ab- oder aufgerissen, denke ich mal. Vielleicht war es hier ein Marder statt einer Eichhörnchenfamilie?

    Melde mich wieder..


    CarScanner Werte im W168 Profil:

    "Abgastemperatur (℃)"
    "Abs. Drosselklappenstellung (%)"
    "Absolutdruck Einlasskanal (kPa)"
    "Berechnete Motorlast (%)"
    "Berechneter Boost (bar)"
    "Berechneter Kraftstoffmengenfluss (L/h)"
    "Berechneter Kraftstoffmengenfluss (L/h)"
    "Berechneter momentaner Kraftstoffverbrauch (L/100km)"
    "Canister Purge Valve duty cycle (%)"
    "Durchschnittsgeschwindigkeit (km/h)"
    "Durchschnittsverbrauch (L/100km)"
    "Durchschnittsverbrauch (gesamt) (L/100km)"
    "Durchschnittsverbrauch 10 sec (L/100km)"
    "Eingangsspannung Steuergerät (V)"
    "Engine Oil Level (mm)"
    "Engine Oil Quality ()"
    "Engine Start Temperature (℃)"
    "Engine Torque ()"
    "Fahrzeugbeschleunigung (g)"
    "Fuel Adaptation Idle at idle speed ()"
    "Fuel Adaptation Lower part load rich at upper part load ()"
    "Fuel Adaptation Upper part load rich at lower part load ()"
    "Fuel tank pressure difference (kPa)"
    "Fuel used since start ()"
    "Geschwindigkeit (km/h)"
    "Idle Speed Adaptation value ()"
    "Kraftstoffkosten ()"
    "Kraftstoffkosten (gesamt) ()"
    "Kühlmitteltemperatur (℃)"
    "Lambda ()"
    "Lambdasonde Sensor 1 Bank 1 (V)"
    "Lambdasonde Sensor 2 Bank 1 (V)"
    "Lufteintrittstemperatur (℃)"
    "MAF Luftdurchsatz (g/sec)"
    "Momentane Motorleistung (basierend auf dem Kraftstoffverbrauch) (kW)"
    "Motordrehzahl (rpm)"
    "OBD Modul (V)"
    "Pedal Value sensor 1 (V)"
    "Pedal Value sensor 2 (V)"
    "Power from MAF (kW)"
    "Target idle speed (calculated value) (rpm)"
    "Throttle Position Voltage 1 (V)"
    "Throttle Position Voltage 2 (V)"
    "Timing Kraftstoffeinspritzung (ms)"
    "verbrauchte Kraftstoffmenge (L)"
    "verbrauchte Kraftstoffmenge (gesamt) (L)"
    "Zündzeitpunkt (°)"
    "zurückgelegte Strecke (km)"
    "zurückgelegte Strecke (gesamt) (km)"
     
  8. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.827
    Zustimmungen:
    4.143
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor + Suzuki GSXF 600 fürs Hobby
    Das sind nicht wirklich schlechte Nachrichten. Ich denke, ihr seid auf den richtigen Weg.

    Klaus
     
  9. #8 Neoback, 14.01.2022
    Neoback

    Neoback Elchfan

    Dabei seit:
    16.05.2020
    Beiträge:
    87
    Zustimmungen:
    52
    Beruf:
    Anlagenmechaniker, Techniker Maschinenbau
    Ort:
    59425 Unna
    Ausstattung:
    W168, A190, Bj. 1999, Automatik, Elegance, Benzin,APS 30
    Marke/Modell:
    Mercedes Benz A190
    Wer doch gut, wenn es die Leitung und Benzilfilter ist. Der Filer sitzt bestimmt zu und durch das Alter des Schlauches ist dieser durch den ausgeübten Druck der Benzipumpe geplatzt. Ich gehe dann davon aus, das du einen neuen Tank brauchtst, da dein alter Tank von innen rostet und somit den Filter immer wieder zu setzt. Ich muss ca. einmal im Jahr den FIler wechseln, aus dem Grund. Den Tank werde ich aber jetzt erst wechseln, sobald mein Elch wieder rennt und ich weiß, dass es sich lohnt diesen zu wechslen.

    Gruß
    Der Neoback
     
  10. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.827
    Zustimmungen:
    4.143
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor + Suzuki GSXF 600 fürs Hobby
    Ich glaube, da ist ein Denkfehler drin. Wenn der Filter zu ist hat man normalerweise keinen Druck mehr auf die Benzinleitung zum Motor.

    Wenn beim Benzinpumpenwechsel gewissenhaft gearbeitet wurde sind die Schläuche zwischen Benzinpumpe und Filter erneuert worden. Da kann also nichts sein, ausser eine Schelle hat aufgegeben.

    Rost im Tank kann man gut mit einer Endoskopkamera mit Beleuchtung sehen.

    Klaus
     
  11. #10 Neoback, 14.01.2022
    Neoback

    Neoback Elchfan

    Dabei seit:
    16.05.2020
    Beiträge:
    87
    Zustimmungen:
    52
    Beruf:
    Anlagenmechaniker, Techniker Maschinenbau
    Ort:
    59425 Unna
    Ausstattung:
    W168, A190, Bj. 1999, Automatik, Elegance, Benzin,APS 30
    Marke/Modell:
    Mercedes Benz A190

    Uups, ich will mich da doch nicht geirrt haben. Ich meine auf den Filter gehen 2 Schläuche und wenn da einer von alt ist, so müsste die Pumpe doch den Druck dahin aufbauen können, sofern die vor den Filter geschaltet ist. Habe ich da den Denkfehler ? Sitzt die Pumpe erst hinterm Filter ???

    Danke für die Erleuchtung :)
    Gruß
    Neoback
     
  12. Rico74

    Rico74 Elchfan

    Dabei seit:
    07.01.2007
    Beiträge:
    170
    Zustimmungen:
    130
    Beruf:
    Technische Betriebsführung
    Ort:
    Stralsund
    Ausstattung:
    L LINKS-Lenkung 525 Connect 20 HIGH (NTG7)
    Marke/Modell:
    W169 Mopf A180 CDI Avantgarde EZ Jan 2011 CVT
    Ja. War aber eine 160-er Premopf. Shop weiß ich nicht mehr.
    Das Steuergerät kam zurück mit eingelöteten LMM aber auch einer neuen kleinen Verstellschraube (Potentiometer?) über die oder auch zusätzlich kalibriert werden sollte.
    Dann hieß es trotzdem ab zum freundlichen zum Anlernen.

    Jede gute Selbsthilfewerkstatt hat Würth, Bosch oder andere Diagnosetools.
     
  13. doko

    doko Elchfan

    Dabei seit:
    30.11.2015
    Beiträge:
    1.827
    Zustimmungen:
    4.143
    Ort:
    Niedersachsen
    Ausstattung:
    SLK R170 200 Kompressor Autom. Leder
    Marke/Modell:
    S203 Kombi 2,0 Automatik + W169 A150 + SLK 200 Kompressor + Suzuki GSXF 600 fürs Hobby
    Moin,

    nee, die Pumpe sitzt im Tank und dann kommt auf dem Weg zum Motor der Filter. Ich bin davon ausgegangen, das die Schläuche von und zur Benzinpumpe beim Pumpenwechsel mit erneuert wurden.

    Wenn die alten noch drin sind kann natürlich auch der Druckschlauch zum Filter undicht sein.

    Meistens ist jedoch der kurze Schlauch vom Filter zur Metallleitung nach vorn und / oder der Schlauch von der Metallleitung zur Einspritzrail im Motorraum undicht.

    Klaus
     
    Neoback gefällt das.
  14. #13 Neoback, 16.01.2022
    Neoback

    Neoback Elchfan

    Dabei seit:
    16.05.2020
    Beiträge:
    87
    Zustimmungen:
    52
    Beruf:
    Anlagenmechaniker, Techniker Maschinenbau
    Ort:
    59425 Unna
    Ausstattung:
    W168, A190, Bj. 1999, Automatik, Elegance, Benzin,APS 30
    Marke/Modell:
    Mercedes Benz A190
    @doko, ich dachte schon ich hätte etwas falsch gesehen. Dann ist ja alles gut !

    Gruß
    Neo
     
  15. Zottel

    Zottel Elchfan

    Dabei seit:
    02.06.2020
    Beiträge:
    282
    Zustimmungen:
    423
    Ort:
    Berlin
    Ausstattung:
    Avantgarde, Schaltgetriebe 6-Gang, Audio 20 (das Alte)
    Marke/Modell:
    W169 A180CDI BJ 2006 (Premopf, Diesel)
    Interessant wäre - ob du an die Diagnosebuchse des W168 zusätzlich die CAN-Leitungen angeschlossen hast - was sie wohl im Original nicht sind. UA @Heisenberg macht das wohl so.

    Hintergrund - im W168-Profil von Carscanner ist ISO 14230-4 KWP (fast init, 10.4 kbaud) als Protokoll ausgewählt - das mWn auf der K-Leitung gesprochen wird. Ein zusätzlicher Anschluss des CAN-Busses an das Diagnoseinterface wäre demnach gar nicht notwendig - lediglich ein angepasster Initialisierungsbefehl in der verwendeten Diagnose-App - den man zB dem W168-Profil von Carscanner entnehmen kann.

    Hat jetzt mit dem eigentlichen Threadthema nicht sooo viel zu tun - aber vermutlich interessant für W168-Fahrer - die nicht unbedingt am CAN-BUS ihres Autos rumlöten wollen - aber trotzdem gerne eine einfache Diagnoseapp hätten.
     
  16. #15 a140l_driver, 23.01.2022
    a140l_driver

    a140l_driver Elchfan

    Dabei seit:
    12.01.2022
    Beiträge:
    5
    Zustimmungen:
    3
    Ort:
    Emmendingen
    Marke/Modell:
    A140L 2003 ca. 230000km
    Erstmal großes Danke an alle die hier mitsuchen, ich versuche mal alle Infos zu sammeln:

    Die (neue) Werkstatt hat das Benzinleck gefunden, es kam zum Überlauf des Aktivkohle-Filter raus. Ursache war ein defekter Kraftstoff-Filter, der an den vier vorhandenen Anschlüssen nicht mehr richtig verteilt hat, bzw. an der falschen Stelle durchlässig war und so das Benzin durch den Kohlefilter rausgedrückt wurde.
    Beide Filter neu und der Druck an der Benzinleitung am Motor bleibt bei ca. 4 bar.
    Ob es am Markenfilter oder am Einbau lag, darauf wollte sich die Werkstatt nicht festlegen (war auch nicht dieselbe Werkstatt, daher..).

    Rost war außen am Tank schon ein Thema. Ich hoffe die Werkstatt hätte mich informiert, wenn im alten Filter was zu sehen gewesen wäre. Schläuche wurden nicht getauscht.

    Der LMM ist separat zu tauschen, das Steuergerät sitzt hinten auf dem Drosselklappengehäuse (heißt das so? Einspritzanlage?), ist also nicht direkt verlötet. Daher wäre ein Einschicken zur Reparatur nicht sinnvoll gewesen (hier beim MOPF).

    An der Buchse habe ich nichts geändert und auch gleich das W168 Profil gewählt. Ob's auch mit einem anderen Profil geht, weiß ich nicht, könnte ich aber testen.

    Gelernt habe ich noch, dass mein Elch ein V168 statt W168 ist. Da wo es Unterschiede gibt, gibt's anscheinend manche Ersatzteile nicht mehr. Aktuell kein Bedarf, hoffe es bleibt erstmal so :-)

    Bin grad von der Gasannahme positiv überrascht, so kalt wie jetzt oder im Sommer war die immer etwas dezenter als bei mittleren Temperaturen. Mal schauen wie es ist, wenn ich neu tanke, wer weiß was die in den Tank geschüttet haben ;-)
     
    Zottel gefällt das.
  17. Anzeige

    Schau mal hier: (hier klicken). Dort findet man Infos und Antworten.

    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  18. #16 Neoback, 24.01.2022
    Neoback

    Neoback Elchfan

    Dabei seit:
    16.05.2020
    Beiträge:
    87
    Zustimmungen:
    52
    Beruf:
    Anlagenmechaniker, Techniker Maschinenbau
    Ort:
    59425 Unna
    Ausstattung:
    W168, A190, Bj. 1999, Automatik, Elegance, Benzin,APS 30
    Marke/Modell:
    Mercedes Benz A190
    Ich lese gerade was von zwei Filtern, ich habe bisher nur einen gefunden, bei meinem Benziner. Sitzt da irgendwo ein Vorfilter noch ?

    Grüße
    Neoback
     
  19. #17 a140l_driver, 25.01.2022
    a140l_driver

    a140l_driver Elchfan

    Dabei seit:
    12.01.2022
    Beiträge:
    5
    Zustimmungen:
    3
    Ort:
    Emmendingen
    Marke/Modell:
    A140L 2003 ca. 230000km
    Gemeint war der Kraftstofffilter und der Aktivkohlefilter, der die Benzindämpfe zurückhalten soll. Wie genau die Schläuche angeschlossen sind, weiß ich leider nicht, und hab auch kein Bild, weil die Werkstatt repariert hat.

    Bernd
     
Thema:

Hilfe bei Fehlersuche - Motorsteuergerät

Die Seite wird geladen...

Hilfe bei Fehlersuche - Motorsteuergerät - Ähnliche Themen

  1. W169 Bitte Hilfe zu Umrüstung Audio 5 CD auf COMAND 2,5 NTG 2

    Bitte Hilfe zu Umrüstung Audio 5 CD auf COMAND 2,5 NTG 2: Ich habe ein A 169 A 200 bj 2005 mit Audio 5 habe mir Comand NTG 2,5 gekauft mit Code.Alles gut .Eingebaut und jetzt steht da Diebstahlschutz...
  2. In eigener Sache! PM Hilfe

    In eigener Sache! PM Hilfe: Liebe Leute, Ich helfe gerne und das jedem. Aber! Bitte wenn ihr euch ein Projekt vornehmt, insbesondere im Bereich KFZ Elektrik, solltet ihr...
  3. W168 Hilfe/Anleitung zum Ausbau der Drosselklappe

    Hilfe/Anleitung zum Ausbau der Drosselklappe: Hallo allerseits, ich möchte bei meinem A170 CDI die Drosselklappe ausbauen. Hat jemand damit Erfahrung bzw. welches Werkzeug wird zum Lösen der...
  4. T245 Hilfe bei "Soundupdate"

    Hilfe bei "Soundupdate": Hallo, Ich bin neu hier im Forum. Meine Lebensgefährtin und ich besitzen seit ca. 2 Wochen auch eine B-Klasse (180er Bj. 2010) Was uns ein...
  5. W168 170 CDI will nicht mehr schalten. Brauche Hilfe bei der Fehlersuche

    170 CDI will nicht mehr schalten. Brauche Hilfe bei der Fehlersuche: Hallo Elchfans, Nachdem ich hier im Forum ja schonmal super Hilfe gefunden habe muss ich mich leider wieder an Euch wenden. Nachdem ich hier in...